ADAMouse I

Repairing, upgrading and maintaining the Miscellaneous Adam Hardware
Post Reply
User avatar
Milli
Site Admin
Posts: 112
Joined: Fri Jul 19, 2019 3:13 pm
Location: Beaver Falls PA
Contact:

ADAMouse I

Post by Milli » Sun Mar 08, 2020 1:01 pm

The ADAMouse I is a mouse that was sold for the Coleco Adam. It plugs into the controller port and gives you mouse functionality to a certain extent. Unlink a standard serial mouse the ADAMouse converts mouse directional movement / mouse ball rolling / to a joystick direction, Up, Down, Left and Right. Now this works fine but it is not like what we are used to today. But on its own the ADAMouse is useless except for the 2 mouse buttons. It requires external power to operate it.

A friend of mine had an ADAMouse that he wanted to use so I told him to send it to me and I would figure it out.
ADAMouse.jpg
ADAMouse.jpg (87.96 KiB) Viewed 1848 times
Upon receiving it I opened it up and used my multi-meter and RS232 breakout adapter to determine what lines did what (as seen from the connector cable end, not the Adam):

Code: Select all

5   4   3   2   1

  9   8   7   6

1 = Not Connected
2 = Right
3 = Left
4 = Down
5 = Up
6 = Not Connected 
7 = Ground
8 = +5 volts DC
9 = Left & Right mouse button
If you are familiar with the Adam controller pin outs then you will know that the Adam does not have +5 volts DC on pin 8 and that pin 9 is the Fire button and pin 1 is the Arm button.

The first think I needed to do was give it a power supply. I toyed with using an accessory adapter like the Rollar ball does but changed my mind.
bad adapter.jpg
bad adapter.jpg (100.85 KiB) Viewed 1848 times
Then I though of splicing a AdamNet cable and using plugging it into where the keyboard goes and then plugging the keyboard into it but decided it was too cumbersome.

After some thoughts I decided to just use a 5V USB charger and cable.

To wire the adapter up I took a male db9 cable and wired lines 1 - 5, 7 & 9 to the corresponding wires on a spare controller plug end I had. Then I wired the positive from the usb to pin 8 of the male connector (not the controller plug) and the ground to the wire on pin 7.

Code: Select all

DB 9    	Adam Controller
Male		Plug
1 -------------	1
2 -------------	2
3 -------------	3
4 -------------	4
5 -------------	5
6 -|	     |-	6
7 -------------	7 - Ground USB
8 -+5v USB   |-	8
9 -------------	9

A "|" means no connection. So line 6 is not connected to anything on either end and line 8 is not connected to anything on the Adam end.
breakout.jpg
breakout.jpg (96.95 KiB) Viewed 1848 times
After wiring this up and testing it I realized that the ADAMouse had been designed to have both the left and right mouse buttons work as the Fire button. Now there may have been logic behind this but it made no sense when you tried to use it. I opend up the mouse and looke at the board and saw that I could cut 2 traces to isolate the right button from the system and then connect it to the Pin 1 wire which was cut off but had enough length to solder on a bridge wire. After connecting this to right button I then also connected pin 9 to it. The Adam fire buttons are strange. When you press Fire pin 9 ground to pin 7. When you press Arm pin 9 grounds to pin 1.
traces.jpg
traces.jpg (88.25 KiB) Viewed 1848 times
wired.jpg
wired.jpg (100.68 KiB) Viewed 1848 times
Now that this was all done I put the mouse back together and started up Paint Master and it works great. Slow but that is because of the style of mouse it is.
AMouse and Adapter.jpg
AMouse and Adapter.jpg (99.52 KiB) Viewed 1848 times
plugged 1.jpg
plugged 1.jpg (55.06 KiB) Viewed 1848 times
plugged2.jpg
plugged2.jpg (49.21 KiB) Viewed 1848 times
Hi.jpg
Hi.jpg (44.51 KiB) Viewed 1848 times
Now that this is done I will make an adapter so that I can use the Commodore 1350 mouse Kevin gave me. I won't make any destructive changes on there is possible as I want to use it with my Commodore 128 also.
Milli

User avatar
Milli
Site Admin
Posts: 112
Joined: Fri Jul 19, 2019 3:13 pm
Location: Beaver Falls PA
Contact:

Re: ADAMouse I

Post by Milli » Sun Mar 15, 2020 1:32 pm

The 1350 I thought I had is an amiga mouse so I can’t use it :(
Milli

Post Reply