MIB238 Card

Posts about Input & Output Cards for the Coleco Adam
Post Reply
User avatar
joltguy
Posts: 86
Joined: Wed Aug 21, 2019 5:17 am
Location: Toronto, Canada
Contact:

MIB238 Card

Post by joltguy » Wed Nov 04, 2020 1:57 pm

Eric Pearson recently announced on Facebook that he has developed a modern drop-in replacement for the legendary MIB3 card. This is truly some great news as its likely the most versatile expansion card ever created for ADAM.

He has generously released his MIB238 as a DIY project available on GitHub. Unfortunately I don't have the skills to do it myself but if anyone out there who does would be interested in building & selling I'd be interested in buying one!

User avatar
Milli
Site Admin
Posts: 189
Joined: Fri Jul 19, 2019 3:13 pm
Location: Beaver Falls PA
Contact:

Re: MIB238 Card

Post by Milli » Wed Nov 04, 2020 6:04 pm

Do you have a serial card?
Milli

User avatar
joltguy
Posts: 86
Joined: Wed Aug 21, 2019 5:17 am
Location: Toronto, Canada
Contact:

Re: MIB238 Card

Post by joltguy » Wed Nov 04, 2020 9:23 pm

I do have an Orphanware/HLM-GMK side expansion box that adds a serial port. For some reason it has recently stopped working for me though. I'm not sure if its an issue with my expansion port or an issue with the device itself. When I go into ADAMLink V terminal mode now it just echoes a few characters like "DDDDDD" and then reports "Carrier Lost". I've tried cleaning the contacts but it didn't help.

User avatar
Milli
Site Admin
Posts: 189
Joined: Fri Jul 19, 2019 3:13 pm
Location: Beaver Falls PA
Contact:

Re: MIB238 Card

Post by Milli » Thu Nov 05, 2020 7:48 am

Try quick term. Are you using a null modem cable?
Milli

User avatar
joltguy
Posts: 86
Joined: Wed Aug 21, 2019 5:17 am
Location: Toronto, Canada
Contact:

Re: MIB238 Card

Post by joltguy » Thu Nov 05, 2020 8:36 am

Milli wrote:
Thu Nov 05, 2020 7:48 am
Try quick term. Are you using a null modem cable?
Ok, I'll give quick term a try.

I am connecting it to a WiModem232. Everything was working flawlessly until last week. I did install my SD-DDP drive last week but I have also since tried removing it and I still have the same issue with the serial port.

User avatar
joltguy
Posts: 86
Joined: Wed Aug 21, 2019 5:17 am
Location: Toronto, Canada
Contact:

Re: MIB238 Card

Post by joltguy » Thu Nov 05, 2020 8:54 am

Same results with quick term. Just a bunch of repeated "D" characters... :?
Attachments
Qterm screenshot
Qterm screenshot
JPEG image-B02B877122D7-1.jpeg (483.45 KiB) Viewed 134 times

User avatar
Milli
Site Admin
Posts: 189
Joined: Fri Jul 19, 2019 3:13 pm
Location: Beaver Falls PA
Contact:

Re: MIB238 Card

Post by Milli » Thu Nov 05, 2020 10:36 am

First you have to set the baud rate (Esc B). And how is it hooked up? Null Modem? or ?
Milli

User avatar
joltguy
Posts: 86
Joined: Wed Aug 21, 2019 5:17 am
Location: Toronto, Canada
Contact:

Re: MIB238 Card

Post by joltguy » Thu Nov 05, 2020 11:06 am

Setting the baud rate made no difference. This happens no matter whether I have the serial cable connected to the WiModem or nothing at all. I don't have a null modem cable.

The even stranger thing is that I still get the stream of D characters even if I don't connect anything to the side port! This leads me to believe it might be an issue with my expansion port and not with the serial device. Maybe I knocked something loose when installing the SD-DDP? Not sure how that could've happened as the installation went smoothly and worked first try but I guess its a possibility.

User avatar
Milli
Site Admin
Posts: 189
Joined: Fri Jul 19, 2019 3:13 pm
Location: Beaver Falls PA
Contact:

Re: MIB238 Card

Post by Milli » Thu Nov 05, 2020 2:23 pm

joltguy wrote:
Thu Nov 05, 2020 11:06 am
Setting the baud rate made no difference. This happens no matter whether I have the serial cable connected to the WiModem or nothing at all. I don't have a null modem cable.

The even stranger thing is that I still get the stream of D characters even if I don't connect anything to the side port! This leads me to believe it might be an issue with my expansion port and not with the serial device. Maybe I knocked something loose when installing the SD-DDP? Not sure how that could've happened as the installation went smoothly and worked first try but I guess its a possibility.
That is possible - There was a post today on facebook of someones system dieing and they have the SD-DDP plugged in - you should post this on FB also - it definitely is not your serial card if its unplugged and the expansion port has nothing to do with the keyboard - the SD-DDP does since it goes through the master 6801 just like the keyboard does.
Milli

User avatar
joltguy
Posts: 86
Joined: Wed Aug 21, 2019 5:17 am
Location: Toronto, Canada
Contact:

Re: MIB238 Card

Post by joltguy » Tue Nov 24, 2020 1:46 pm

I know most people on here are likely on the Facebook group too but just in case: John Lundy has built a few of the aforementioned MIB238 cards and is offering them for sale :arrow: https://www.facebook.com/groups/1155310 ... 9174907845

Already ordered mine! :)

Post Reply